无法在我的Python IDLE中导入pyperclip,但可以从命令提示符导入。

这是我在stackoverflow上的第一个问题,我是Python新手。

我想导入pyperclip模块。于是我进入cmd,以管理员身份运行,使用- cd \Program Files\Python37\Scripts移动到路径,并通过pip3 install pyperclip命令下载pip,它被成功下载。

现在从IDLE中我无法导入它

以下是IDLE的输出,它没有得到pyperclip模块的导入。

Python 3.8.2 (tags/v3.8.2:7b3ab59, Feb 25 2020, 22:45:29) [MSC v.1916 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license()" for more information.
>>> import pyperclip
Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import pyperclip
ModuleNotFoundError: No module named 'pyperclip'
>>> 

在这之后,我做了一些研究,发现它有可能安装在其他目录下,所以我在其中一个子目录下找到了pyperclip文件夹和pyperclip-1.8.0-py3.6.egg-info文件夹,我把它复制并粘贴在C:\\Program Files\Python36目录下。

有了以上的问题,我也无法从IDLE导入pyperclip。

我进入命令提示符,输入python,可以导入它

以下是输出C:\Users\Administrator>python。

Python 3.6.0 (v3.6.0:41df79263a11, Dec 23 2016, 08:06:12) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import pyperclip
>>>

所以我不能从IDLE导入,但可以在命令提示符下导入。

我还发现了一个问题,因为我是一个新的Python新手,IDLE显示Python 3.8.2,而在命令提示符下却显示3.6,我只下载了一个Python,而且只安装了一个Python。 我只下载了一个Python,也只安装了一个Python,为什么会出现3.6和3.8.2的版本差异?

更新:在IDLE上使用以下命令,我可以导入pyperclip。但它只适用于当前打开的IDLE。关闭IDLE后再重新打开,我又要执行这些命令。如何解决这个问题?

>>> import sys
>>> sys.path.insert(1, 'C:/Program Files/Python36')
>>> import pyperclip
~~~~~~~~~~

SOLVED:

解决方案:

在你的例子中,IDLE 使用的是一个 Python 解释器 (Python 3.8.2),而在命令行中你运行的是另一个 (Python 3.6.0),并安装了 pyperclip。你最好做以下步骤中的一个。

1) 使用多个虚拟环境来轻松解决这个问题 (推荐)。阅读 这个 的文章中获取更多信息。

2) 在两个 Python 解释器上安装所需的模块,通过运行 pip install pyperclip 或者(取决于Python版本)从 C:\PythonXX\ScriptsC:\Program files\PythonXX\Scripts

3) 你也可以在你的机器上使用单个Python解释器:删除其中一个解释器,然后 “修复 “另一个解释器 (修复文件类型关联)。要做到这一点,请从 Windows 卸载管理器中打开安装程序,并按照它给你的步骤进行操作。

给TA打赏
共{{data.count}}人
人已打赏
解决方案

有两个选择的数组让我只走了一半的路。

2022-5-14 18:00:11

解决方案

空离子含量与谷歌地图 - Ionic2

2022-5-14 18:00:13

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索