有没有修复Parse-SDK-Android:parse:1.24.0的方法?

当我试图下载Parse-SDK-Android:parse:1.24.0时,总是得到这个错误。

误区

ERROR: Unable to resolve dependency for ‘:app@debugcompileClasspath’: 无法找到 com.github.parse-community.Parse-SDK-Android:parse:1.24.0.显示详情受影响的模块:app。

解决方案:

我面临着完全相同的问题,浪费了几个小时后,我能够解决它,并能够连接到我在AWS上的解析服务器。但我对Parsse平台提供的文档不满意(https:/docs.parseplatform.organdroidguide),它建议加入这个依赖关系。

当我在模块构建文件中加入了以下依赖关系后,它对我来说是有效的。

implementation 'com.parse.bolts:bolts-tasks:1.4.0'
implementation "com.parse:parse-android:1.17.3"

并在项目构建文件中的仓库部分加入了以下内容

maven { url "https://jitpack.io" }

到目前为止,我还不知道为什么com.github.parse-community.Parse-SDK-Android:parse:1.24.0会出现问题。请注意,我能够连接到parse服务器。如果你面临连接问题,我也提供以下修改。Manifest文件修改(必须添加android:name) :

<applicationandroid:name=”.ParseApplication”

并初始化Parse应用程序。

public void onCreate() {
    super.onCreate();
    Parse.initialize(new Parse.Configuration.Builder(this)
            .applicationId("myappID")
            // if defined
            .clientKey("xxxxxxxx")
            .server("http://13.232.198.174/parse/")
            .build()
    );

本文来自投稿,不代表运维实战侠立场,如若转载,请注明出处:https://www.shizhanxia.com/813.html

(0)
上一篇 2022年6月29日 下午4:00
下一篇 2022年6月29日 下午4:00

相关推荐

发表评论

登录后才能评论