被apt –fix-broken安装卡住了(libc6:amd64包安装后)。

我的系统运行在WSL里面,我每隔几天就会租借升级一次.我卡在一个包的安装上,正在寻找解决这个问题的方法。

$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libbind9-161 libdns-export1107 libdns1107 libdns1109 libirs161 libisc-export1104 libisc1104 libisc1105 libisccc161
  libisccfg163 liblwres161 liboauth0
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libc-bin
The following packages will be upgraded:
  libc-bin
1 upgraded, 0 newly installed, 0 to remove and 882 not upgraded.
6 not fully installed or removed.
Need to get 0 B/633 kB of archives.
After this operation, 8,192 B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up libc6:amd64 (2.31-0ubuntu6) ...
Checking for services that may need to be restarted...
Checking init scripts...
Nothing to restart.
sleep: cannot read realtime clock: Invalid argument
dpkg: error processing package libc6:amd64 (--configure):
 installed libc6:amd64 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

接下来我可以尝试什么?

解决方案:

我遇到了同样的问题,这个过程从 此错误报告 固定它。

编辑: /var/lib/dpkg/info/libc6\:amd64.postinst

并划线

# set -e

所以美元 apt-get -f install 可以继续。

给TA打赏
共{{data.count}}人
人已打赏
解决方案

如何在不同的地方用唯一的ID使用一个类组件?

2022-4-20 11:08:46

解决方案

在PHP中从preg_match_all中返回的值

2022-4-20 12:08:40

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索